lkml.org 
[lkml]   [2014]   [Jul]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH 2/5] Input - wacom: use a specific name for the battery device
Date
The current implementation uses "wacom_battery" as a generic name for
batteries. This prevents us to have two Wacom devices with a battery
attached as the power system will complain about the name which is already
registered.

Use a specific name for each type of battery attached.

A bug in upower prevents us to use spaces in the power name, so replace
each space by '_'.

Signed-off-by: Benjamin Tissoires <benjamin.tissoires@redhat.com>
---
drivers/input/tablet/wacom_sys.c | 13 ++++++++++---
drivers/input/tablet/wacom_wac.h | 1 +
2 files changed, 11 insertions(+), 3 deletions(-)

diff --git a/drivers/input/tablet/wacom_sys.c b/drivers/input/tablet/wacom_sys.c
index 1888709..b5d75a4 100644
--- a/drivers/input/tablet/wacom_sys.c
+++ b/drivers/input/tablet/wacom_sys.c
@@ -803,15 +803,21 @@ static int wacom_battery_get_property(struct power_supply *psy,
return ret;
}

-static int wacom_initialize_battery(struct wacom *wacom)
+static int wacom_initialize_battery(struct wacom *wacom, const char *name)
{
int error = 0;
+ int i;

if (wacom->wacom_wac.features.quirks & WACOM_QUIRK_MONITOR) {
wacom->battery.properties = wacom_battery_props;
wacom->battery.num_properties = ARRAY_SIZE(wacom_battery_props);
wacom->battery.get_property = wacom_battery_get_property;
- wacom->battery.name = "wacom_battery";
+ sprintf(wacom->wacom_wac.bat_name, "%s battery", name);
+ for (i=0; i < strlen(wacom->wacom_wac.bat_name); i++) {
+ if (wacom->wacom_wac.bat_name[i] == ' ')
+ wacom->wacom_wac.bat_name[i] = '_';
+ }
+ wacom->battery.name = wacom->wacom_wac.bat_name;
wacom->battery.type = POWER_SUPPLY_TYPE_BATTERY;
wacom->battery.use_for_apm = 0;

@@ -1012,7 +1018,8 @@ static void wacom_wireless_work(struct work_struct *work)
wacom_wac->shared->touch_input = wacom_wac2->input;
}

- error = wacom_initialize_battery(wacom);
+ error = wacom_initialize_battery(wacom,
+ wacom_wac1->features.name);
if (error)
goto fail;
}
diff --git a/drivers/input/tablet/wacom_wac.h b/drivers/input/tablet/wacom_wac.h
index 68cf257..7565be5 100644
--- a/drivers/input/tablet/wacom_wac.h
+++ b/drivers/input/tablet/wacom_wac.h
@@ -153,6 +153,7 @@ struct wacom_shared {
struct wacom_wac {
char name[WACOM_NAME_MAX];
char pad_name[WACOM_NAME_MAX];
+ char bat_name[WACOM_NAME_MAX];
unsigned char data[WACOM_PKGLEN_MAX];
int tool[2];
int id[2];
--
2.0.0


\
 
 \ /
  Last update: 2014-07-10 22:21    [W:0.096 / U:0.808 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site