[lkml]   [2014]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: 3.15.2 build error on AMD64
On Mon, Jun 30, 2014 at 07:51:00PM +0100, Nick Warne wrote:
> Ummm, interesting.
> But is it solved?
> Suppose developer a.n.other submits a patch that works with his/her GCC
> version but doesn't with some other GCC version. I guess this will be
> picked up in GIT build tests, but that only then tells everybody to upgrade
> GCC or find a patch that fixes the issue (like you did, but I couldn't find
> it).

Well, this is generally something that will have to get fixed when
someone reports it. That's why I wanted to have an ancient environment
to build kernels in - just for that purpose. We have a bunch of people
who do test latest kernels on ancient hw and sw but as it is always the
case with testing, we cannot have total coverage.

So yes, in such cases, we aim at having the kernel build with all
supported gcc versions. Which brings me to your question below...

> Is there a document or something that stipulates what is the minimum
> version[s] of GCC to build a particular version of the kernel? If not,
> perhaps this is something that needs addressing.

#if GCC_VERSION < 30200
# error Sorry, your compiler is too old - please upgrade it.

... yes, so we do support gcc versions >= 3.2 and the kernel has to be
buildable with those.

So, long story short, people should report such issues to lkml so that
they get addressed.




Sent from a fat crate under my desk. Formatting is fine.

 \ /
  Last update: 2014-06-30 21:41    [W:0.057 / U:8.068 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site