lkml.org 
[lkml]   [2014]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] ring-buffer: Fix polling on trace_pipe
On Thu, 26 Jun 2014 11:34:46 -0700
Martin Lau <kafai@fb.com> wrote:

> Hi Steve,
>
> Can the modified test program reproduce the problem in your test setup?

Ah sorry, got distracted by other work.

OK, I just tried it out, and here's my results:

I ran you code with my current kernel and this is what I got:

# ./ftrace-test-epoll-kafai
<...>-3183 [002] ...1 81.777891: tracing_mark_write:
some data 3183: waitting for more data......
3184: written more data

And it just hung there.


Then I applied your patch, compiled and booted it, and ran the test
again, and I got this:

# ./ftrace-test-epoll-kafai

It just hung there. No forward progress.

I don't think that was the result you intended.

-- Steve




\
 
 \ /
  Last update: 2014-06-27 03:21    [W:0.163 / U:44.372 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site