lkml.org 
[lkml]   [2014]   [Jun]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Subject[PATCH] kernel.h: Remove deprecated pack_hex_byte
From
Date
It's been nearly 3 years now since commit 55036ba76b2d
("lib: rename pack_hex_byte() to hex_byte_pack()") so it's
time to remove this deprecated and unused static inline.

Signed-off-by: Joe Perches <joe@perches.com>
---
include/linux/kernel.h | 5 -----
1 file changed, 5 deletions(-)

diff --git a/include/linux/kernel.h b/include/linux/kernel.h
index 44649e0..2416c82 100644
--- a/include/linux/kernel.h
+++ b/include/linux/kernel.h
@@ -493,11 +493,6 @@ static inline char *hex_byte_pack_upper(char *buf, u8 byte)
return buf;
}

-static inline char * __deprecated pack_hex_byte(char *buf, u8 byte)
-{
- return hex_byte_pack(buf, byte);
-}
-
extern int hex_to_bin(char ch);
extern int __must_check hex2bin(u8 *dst, const char *src, size_t count);




\
 
 \ /
  Last update: 2014-06-24 22:21    [W:0.027 / U:0.212 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site