lkml.org 
[lkml]   [2014]   [Apr]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectshould we change the name/macros of file-private locks?
Sorry to spam so many lists, but I think this needs widespread
distribution and consensus.

File-private locks have been merged into Linux for v3.15, and *now*
people are commenting that the name and macro definitions for the new
file-private locks suck.

...and I can't even disagree. They do suck.

We're going to have to live with these for a long time, so it's
important that we be happy with the names before we're stuck with them.

Michael Kerrisk suggested several names but I think the only one that
doesn't have other issues is "file-associated locks", which can be
distinguished against "process-associated" locks (aka classic POSIX
locks).

At the same time, he suggested that we rename the command macros since
the 'P' suffix would no longer be relevant. He suggested something like
this:

F_FA_GETLK
F_FA_SETLK
F_FA_SETLKW

That would also make them more visually distinguishable from the
classic F_GETLK/F_SETLK/F_SETLKW commands. I like that change in
particular, as the original macros names would be easy to typo.

I think we'd also need to rename how these are reported in /proc/locks.
Currently they have a type label of "FLPVT". I'd suggest that we
change that to "FASSOC". For v3.15, this is the only part we'd
absolutely have to change before it ships. The rest I can fix up in
v3.16.

Does this sound like a reasonable set of changes to make? Does anyone
else have a better set of names they can suggest? Speak now, or forever
hold your peace!

--
Jeff Layton <jlayton@redhat.com>


\
 
 \ /
  Last update: 2014-04-16 22:01    [W:0.093 / U:9.840 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site