lkml.org 
[lkml]   [2014]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Missing USB XHCI and EHCI reset for kexec
From
Date
Am Dienstag, den 15.04.2014, 15:05 -0400 schrieb Alan Stern:
> On Tue, 15 Apr 2014, Stefani Seibold wrote:
>
> > > One other thing you can try is to increase the reset timeout in
> > > drivers/usb/host/ehci-hub.c. This is under the USB_PORT_FEAT_RESET
> > > case in ehci_hub_control(), around line 1225:
> > >
> > > /*
> > > * caller must wait, then call GetPortStatus
> > > * usb 2.0 spec says 50 ms resets on root
> > > */
> > > ehci->reset_done [wIndex] = jiffies
> > > + msecs_to_jiffies (50);
> > >
> > > Increasing the 50 to 100 or more might help.
> > >
> > > Alan Stern
> > >
> >
> > I tried this, when i increase the value to 1000, the reset and
> > enumeration process will be faster after a kexec: 28 Seconds vs. 162
> > Seconds.
>
> Even 28 seconds is much longer than it should be. And a 1000-ms long
> reset signal is a lot longer than any device should need.
>
> Anyway, since you saw the same problem after unbind and rebind, you
> don't have to perform a kexec for testing.
>

Right, but i would prefer a solution for this. Since it works perfectly
in kernel 3.4 i don't think it is a hardware issue.

- Stefani




\
 
 \ /
  Last update: 2014-04-15 22:01    [W:0.068 / U:0.580 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site