[lkml]   [2014]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 3/3] cgroup: implement cgroup.subtree_populated for the default hierarchy

On Tue, Apr 15, 2014 at 08:57:21AM +0800, Li Zefan wrote:
> Is cgroup.tree_populated a better name?
> cgroup.subtree_control controls child cgroups only, but .subtree_populated
> shows 1 if there're tasks in the cgroup or its children, so the two
> are a bit inconsistent to me.

Yes, good catch. subtree_control affects subtree proper.
subtree_populated covers self too. The difference is subtle and the
trade off between shared pattern in names and clarifying the subtlety
didn't seem clear-cut to me. Hmmm....


 \ /
  Last update: 2014-04-15 18:21    [W:0.117 / U:0.300 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site