lkml.org 
[lkml]   [2014]   [Apr]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC][2/11][MANUX] Kernel compatibility : uname(2)
> Thus, I decided to fake a Linux-like answer on this syscall, and
> implement another syscall where I could put what I wanted. In practice,
> I currently identify myself as "Linux 2.6.35" through uname(2), but
> "Manux 0.0.5" through my uname_vect(2) syscall.
>
> Is it okay to do this? Do you have any objections or remarks?

If you are trying to be ABI compatible then replying with a "Linux"
version that it is compatible with might actually be extraordinarily
sensible.

Alan


\
 
 \ /
  Last update: 2014-04-15 17:41    [W:0.032 / U:1.736 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site