lkml.org 
[lkml]   [2014]   [Mar]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject[PATCHv4 0/5] Common Mailbox Framework
Date
Hi,
Here is the next revision of Mailbox code.

Changes since v3:
o Change name of symbols from ipc to mbox
o Return real types instead of void *
o Align structures
o Change some symbol names
rxcb -> rx_callback
txcb -> tx_done
o Added kernel-doc for exported API
o Dropped the cl_id and use clients pointer for callbacks.
o Fixed locking of channel pool
o Return negative error code for unsuccessful ipc_send_message()
o Module referencing during mailbox assignment to a client.
o Made error code symbols specific to mailbox.

Thanks
Jassi


\
 
 \ /
  Last update: 2014-03-18 20:21    [W:0.213 / U:4.404 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site