lkml.org 
[lkml]   [2014]   [Nov]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [RFC][PATCH 05/12 v3] tracing: Convert seq_buf fields to be like seq_file fields
On Tue 2014-11-04 10:52:42, Steven Rostedt wrote:
> From: "Steven Rostedt (Red Hat)" <rostedt@goodmis.org>
>
> In facilitating the conversion of seq_file to use seq_buf,
> have the seq_buf fields match the types used by seq_file.
>
> Signed-off-by: Steven Rostedt <rostedt@goodmis.org>
> ---
> include/linux/seq_buf.h | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/include/linux/seq_buf.h b/include/linux/seq_buf.h
> index 6d1c57d6073f..a4d114e6f740 100644
> --- a/include/linux/seq_buf.h
> +++ b/include/linux/seq_buf.h
> @@ -19,10 +19,10 @@
> * @overflow: Set if more bytes should have been written to buffer
> */
> struct seq_buf {
> - unsigned char *buffer;
> - unsigned int size;
> - unsigned int len;
> - unsigned int readpos;
> + char *buffer;

It would make sense to use "char" from the beginning. In fact, it is
already used on many locations in seq_buf.c. Or we might want to get
rid of "unsigned char" in seq_buf.c here as well.

> + size_t size;
> + size_t len;
> + loff_t readpos;

I have just noticed that the variable is called "read_pos" in
seq_file. Are you going to sync the name later?

Also I am a bit curious that "readpos" use another type than "len"
and "size". Well, this is not in the scope of this patchset. I am fine
with keeping "loff_t" at this point.

Best Regards,
Petr


\
 
 \ /
  Last update: 2014-11-05 17:01    [W:0.540 / U:0.064 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site