lkml.org 
[lkml]   [2014]   [Nov]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 2/2] move imx-hdmi to bridge/dw-hdmi
Hi,

On 04/11/14 13:39, Andy Yan wrote:
> From: Andy yan <andy.yan@rock-chips.com>
>
> the original imx hdmi driver is under staging/imx-drm,
> which depends on imx-drm, so move the imx hdmi drvier out
> to drm/bridge and rename imx-hdmi to dw-hdmi
>
> Change-Id: I5f417372f256aa26cd00a3cd0160741680afd39d
> ---
> drivers/gpu/drm/bridge/Kconfig | 5 +
> drivers/gpu/drm/bridge/Makefile | 1 +
> drivers/gpu/drm/bridge/dw_hdmi.c | 1651 +++++++++++++++++++++++++++++++++
> drivers/gpu/drm/bridge/dw_hdmi.h | 1032 +++++++++++++++++++++
> drivers/staging/imx-drm/Kconfig | 1 +
> drivers/staging/imx-drm/Makefile | 2 +-
> drivers/staging/imx-drm/dw_hdmi-imx.c | 66 +-
> drivers/staging/imx-drm/imx-hdmi.c | 1651 ---------------------------------
> drivers/staging/imx-drm/imx-hdmi.h | 1032 ---------------------
> include/drm/bridge/dw_hdmi.h | 26 +-
> 10 files changed, 2737 insertions(+), 2730 deletions(-)
> create mode 100644 drivers/gpu/drm/bridge/dw_hdmi.c
> create mode 100644 drivers/gpu/drm/bridge/dw_hdmi.h
> delete mode 100644 drivers/staging/imx-drm/imx-hdmi.c
> delete mode 100644 drivers/staging/imx-drm/imx-hdmi.h
>


Could you try generating this patch with the -M option?

git format-patch should then understand its a rename.
Then it should generate a smaller patch that is possible to review easily.

Thanks
ZubairLK


\
 
 \ /
  Last update: 2014-11-04 15:01    [W:1.542 / U:1.760 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site