lkml.org 
[lkml]   [2014]   [Nov]   [18]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 1/2] sched/deadline: Modify cpudl.free_cpus to reflect rd->span
From
On 18 November 2014 03:39, Steven Rostedt <rostedt@goodmis.org> wrote:
> On Tue, 18 Nov 2014 00:11:03 +0800
>
>> index 539ca3c..9a69353
>> --- a/kernel/sched/cpudeadline.c
>> +++ b/kernel/sched/cpudeadline.c
>> @@ -107,7 +107,9 @@ int cpudl_find(struct cpudl *cp, struct task_struct *p,
>> int best_cpu = -1;
>> const struct sched_dl_entity *dl_se = &p->dl;
>>
>> - if (later_mask && cpumask_and(later_mask, later_mask, cp->free_cpus)) {
>> + if (later_mask && cpumask_and(later_mask, cp->free_cpus,
>> + &p->cpus_allowed) && cpumask_and(later_mask,
>> + later_mask, cpu_active_mask)) {
>
> I did a quick review of this patch, and it looks fine to me. But the
> above looks ugly. Please change it to something more readable like:

Yes, the following looks beautiful. I'll adjust it, thanks!
>
> if (later_mask &&
> cpumask_and(later_mask, cp->free_cpus, &p->cpus_allowed) &&
> cpumask_and(later_mask, later_mask, cpu_active_mask)) {
>
> Thanks,
>
> -- Steve
>
>
>> best_cpu = cpumask_any(later_mask);
>> goto out;
>> } else if (cpumask_test_cpu(cpudl_maximum(cp), &p->cpus_allowed) &&
>> @@ -186,6 +188,17 @@ out:
>> }
>>
>


\
 
 \ /
  Last update: 2014-11-18 15:01    [W:0.059 / U:0.192 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site