lkml.org 
[lkml]   [2013]   [Sep]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v1 7/7] jump_label: use defined macros instead of hard-coding for better readability

[ Added Jason to Cc. ]

On Wed, 25 Sep 2013 23:47:19 +0800
Jiang Liu <liuj97@gmail.com> wrote:

> On 09/25/2013 10:53 PM, Steven Rostedt wrote:
> > On Wed, 25 Sep 2013 18:44:27 +0800
> > Jiang Liu <liuj97@gmail.com> wrote:
> >
> >> From: Jiang Liu <jiang.liu@huawei.com>
> >>
> >> Use macro JUMP_LABEL_TRUE_BRANCH instead of hard-coding for better
> >> readability.
> >>
> >> Signed-off-by: Jiang Liu <jiang.liu@huawei.com>
> >> Cc: Jiang Liu <liuj97@gmail.com>
> >> ---
> >> include/linux/jump_label.h | 3 ++-
> >> 1 file changed, 2 insertions(+), 1 deletion(-)
> >>
> >> diff --git a/include/linux/jump_label.h b/include/linux/jump_label.h
> >> index a507907..b697fbd 100644
> >> --- a/include/linux/jump_label.h
> >> +++ b/include/linux/jump_label.h
> >> @@ -116,7 +116,8 @@ extern void static_key_slow_dec(struct static_key *key);
> >> extern void jump_label_apply_nops(struct module *mod);
> >>
> >> #define STATIC_KEY_INIT_TRUE ((struct static_key) \
> >> - { .enabled = ATOMIC_INIT(1), .entries = (void *)1 })
> >> + { .enabled = ATOMIC_INIT(1), \
> >> + .entries = (void *)JUMP_LABEL_TRUE_BRANCH })
> >> #define STATIC_KEY_INIT_FALSE ((struct static_key) \
> >> { .enabled = ATOMIC_INIT(0), .entries = (void *)0 })
> >>
> >
> > Probably should add a comment that there is no
> > "JUMP_LABEL_FALSE_BRANCH" or maybe we should add one?
> Hi Steven,
> How about
> JUMP_LABEL_TYPE_MASK/JUMP_LABEL_TRUE_BRANCH/JUMP_LABEL_FALSE_BRANCH
> tuple? That should have the best readability.
> Thanks!
>

You mean a mask of ~1, and TRUE be 1 and FALSE be 0.

That may work.

-- Steve


\
 
 \ /
  Last update: 2013-09-25 18:41    [W:0.053 / U:0.072 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site