lkml.org 
[lkml]   [2013]   [Jun]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: trouble building 'perf' for 3.9.7
From
Date

Greetings --

I wrote:

> Anyway, this worked fine for 2.6.late, as well as 3.0 stable and 3.4
> stable. However, I wanted the improvements to 'usbip', so I switched
> to 3.9; currently I'm using 3.9.7.
>
> Using exactly the same scripts (see below), perf now fails to build:

I have to eat some of those words.

I tried switching back to 3.4, and the build still failed. I'm
mystified, as I thought I had done a full rebuild with that kernel,
but maybe I hadn't (and the build succeeded due to bits left over from
earlier kernels).

The final fix (for 3.4 -- testing with 3.9 now) was to *not* point the
perf build at the target ("staging") headers. Instead, perf finds the
sysroot headers installed as a part of the cross-compile toolchain.

This left issues with elfutils, but I changed that build step to put
them in a custom subdirectory. That way, I could configure perf to
use that location without pulling in the sanitized headers.

Sorry if anyone wasted their time chasing down my carelessness.

(Although, to be fair, 'perf' is the only package out of about 20 that
fails when I explicitly point the build at the target's "include"
directory.)

Thanks again!

Best regards,
Anthony Foiani


\
 
 \ /
  Last update: 2013-07-01 00:01    [W:0.033 / U:37.984 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site