lkml.org 
[lkml]   [2013]   [May]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [PATCH 02/14] misc/ep93xx_pwm: use {read,write}* instead of __raw_* versions for io
Date
On Saturday 25 May 2013, H Hartley Sweeten wrote:
> @@ -42,13 +42,13 @@ struct ep93xx_pwm {
> static inline void ep93xx_pwm_writel(struct ep93xx_pwm *pwm,
> unsigned int val, unsigned int off)
> {
> - __raw_writel(val, pwm->mmio_base + off);
> + writel(val, pwm->mmio_base + off);
> }

Just an idea: since you are adding the writel in a lot of places in subsequent
patches, you could rename 'mmio_base' to the shorter 'base' first, which would
make the resulting code actually smaller.

Arnd


\
 
 \ /
  Last update: 2013-05-27 18:01    [W:0.034 / U:0.020 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site