lkml.org 
[lkml]   [2013]   [May]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: RTL driver for RTL8191SEvB and/or wpa-supplicant really broken at times
From
Hi everyone,

sorry for the late reply, business trip to Tokyo.

On Do, 09 Mai 2013, Larry Finger wrote:
> absolutely critical, namely the PCI ID. There are at least three

10ec:8172

> I also recommend that you try either the wireless-testing git repo or the
> mainline git repo. There are a lot of changes that cannot be backported.

Ok, I will try.

On Fr, 10 Mai 2013, Matt Causey wrote:
> Seems to indicate that the access point is ignoring your probe requests.
> If that is happening for your client somehow, wpa_supplicant won't work
> well. :-)

I rebooted the rooter, after that it worked, for one day. After that
agian problems.

Then I rebooted also linux and it works again.

> "NecAcces" - but I'm not familiar with that vendor. Also, do you have a

Aterm WR8600N http://121ware.com/aterm/
which is a NEC part, probably sold in other places under a different
name. In Japan it is sold as this.

> WLAN packet capture (from another host nearby on the same channel)? That
> would be helpful as well.

Difficult, I only have an iPhone, and a wireless repeater for the TV,
and I guess both are not enough for wlan sniffing.

In the meantime I have also tried wpa_supplicatn 2.0, without
chagnes.

In the current log there are strange things:
May 15 20:36:38 tofuschnitzel kernel: [78541.678861] wlan0: send auth to 00:3a
:9d:b4:54:5a (try 1/3)
May 15 20:36:38 tofuschnitzel NetworkManager[16128]: <info> (wlan0): supplican
t interface state: scanning -> authenticating
May 15 20:36:38 tofuschnitzel kernel: [78541.681046] wlan0: authenticated
May 15 20:36:43 tofuschnitzel kernel: [78546.680713] wlan0: deauthenticating from 00:3a:9d:b4:54:5a by local choice (reason=3)
May 15 20:36:43 tofuschnitzel NetworkManager[16128]: <info> (wlan0): supplicant interface state: authenticating -> disconnected
May 15 20:36:44 tofuschnitzel NetworkManager[16128]: <info> (wlan0): supplicant interface state: disconnected -> scanning

Why does it go from authenticated -> directly to deauthenticating. Uffa.

Anyway, I will try some more things, esp wireless-testing.

Norbert

------------------------------------------------------------------------
PREINING, Norbert http://www.preining.info
JAIST, Japan TeX Live & Debian Developer
DSA: 0x09C5B094 fp: 14DF 2E6C 0307 BE6D AD76 A9C0 D2BF 4AA3 09C5 B094
------------------------------------------------------------------------


\
 
 \ /
  Last update: 2013-05-15 15:21    [W:0.140 / U:0.924 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site