lkml.org 
[lkml]   [2013]   [Feb]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] Doc: percpu_counter doc code for better readability
On Tue, Jan 29, 2013 at 09:31:56AM +0100, Jesper Dangaard Brouer wrote:
> Help people reading the percpu_counter code, to notice the ifdef
> else statement that seperates CONFIG_SMP.
>
> Signed-off-by: Jesper Dangaard Brouer <brouer@redhat.com>
> ---
>
> include/linux/percpu_counter.h | 2 +-
> 1 files changed, 1 insertions(+), 1 deletions(-)
>
> diff --git a/include/linux/percpu_counter.h b/include/linux/percpu_counter.h
> index b9df9ed..eded1aa 100644
> --- a/include/linux/percpu_counter.h
> +++ b/include/linux/percpu_counter.h
> @@ -83,7 +83,7 @@ static inline int percpu_counter_initialized(struct percpu_counter *fbc)
> return (fbc->counters != NULL);
> }
>
> -#else
> +#else /* No CONFIG_SMP */

"#else /* !CONFIG_SMP */" would be more conventional. Can you please
change that and repost it w/ my Acked-by and [TRIVIAL] tag added and
Jiri Kosina <trivial@kernel.org> cc'd?

Thanks.

--
tejun


\
 
 \ /
  Last update: 2013-02-04 23:43    [W:0.057 / U:3.808 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site