lkml.org 
[lkml]   [2013]   [Feb]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
From
Subject[PATCH] ia64: rename cache_show to topology_cache_show
Date
Fenguang Wu has reported the following compile time issue
arch/ia64/kernel/topology.c:278:16: error: conflicting types for 'cache_show'
include/linux/slab.h:224:5: note: previous declaration of 'cache_show' was here

which has been introduced by 749c5415 (memcg: aggregate memcg cache
values in slabinfo). Let's rename ia64 local function to prevent from
the name conflict.

Reported-by: Fenguang Wu <fengguang.wu@intel.com>
Signed-off-by: Michal Hocko <mhocko@suse.cz>
---
arch/ia64/kernel/topology.c | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

diff --git a/arch/ia64/kernel/topology.c b/arch/ia64/kernel/topology.c
index c64460b..d9e2152 100644
--- a/arch/ia64/kernel/topology.c
+++ b/arch/ia64/kernel/topology.c
@@ -275,7 +275,8 @@ static struct attribute * cache_default_attrs[] = {
#define to_object(k) container_of(k, struct cache_info, kobj)
#define to_attr(a) container_of(a, struct cache_attr, attr)

-static ssize_t cache_show(struct kobject * kobj, struct attribute * attr, char * buf)
+static ssize_t topology_cache_show(struct kobject * kobj,
+ struct attribute * attr, char * buf)
{
struct cache_attr *fattr = to_attr(attr);
struct cache_info *this_leaf = to_object(kobj);
@@ -286,7 +287,7 @@ static ssize_t cache_show(struct kobject * kobj, struct attribute * attr, char *
}

static const struct sysfs_ops cache_sysfs_ops = {
- .show = cache_show
+ .show = topology_cache_show
};

static struct kobj_type cache_ktype = {
--
1.7.10.4


\
 
 \ /
  Last update: 2013-02-15 14:21    [W:0.047 / U:0.112 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site