lkml.org 
[lkml]   [2013]   [Dec]   [16]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Xen-devel] [RFC PATCH 4/5] xen/pciback: Move the FLR code to a function.
>>> On 13.12.13 at 17:09, Konrad Rzeszutek Wilk <konrad.wilk@oracle.com> wrote:
> +void pcistub_reset_pci_dev(struct pci_dev *dev)
> +{
> + /* This is OK - we are running from workqueue context
> + * and want to inhibit the user from fiddling with 'reset'
> + */
> +
> + dev_dbg(&dev->dev, "resetting (FLR, D3, etc) the device\n");
> +
> + pci_reset_function(dev);
> + pci_restore_state(dev);
> +
> + /* This disables the device. */
> + xen_pcibk_reset_device(dev);
> +
> + /* And cleanup up our emulated fields. */
> + xen_pcibk_config_reset_dev(dev);
> +}

Ah, here it comes. Improperly split series then...

Jan



\
 
 \ /
  Last update: 2013-12-16 11:01    [W:0.218 / U:0.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site