lkml.org 
[lkml]   [2013]   [Nov]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 6/6] jfs: simplify lmLogSync() via list_last_entry_or_null()
Hi Dave and all,

Please ignore this patch from this series.

On 11/15 2013 12:35 PM, Jeff Liu wrote:
> From: Jie Liu <jeff.liu@oracle.com>
>
> Simplify the code in lmLogSync() via list_last_entry_or_null().
>
> Signed-off-by: Jie Liu <jeff.liu@oracle.com>
> ---
> fs/jfs/jfs_logmgr.c | 10 +++-------
> 1 file changed, 3 insertions(+), 7 deletions(-)
>
> diff --git a/fs/jfs/jfs_logmgr.c b/fs/jfs/jfs_logmgr.c
> index 7b565d0..2f90779 100644
> --- a/fs/jfs/jfs_logmgr.c
> +++ b/fs/jfs/jfs_logmgr.c
> @@ -963,13 +963,9 @@ static int lmLogSync(struct jfs_log * log, int hard_sync)
>
> if (log->sync == log->syncpt) {
> LOGSYNC_LOCK(log, flags);
> - if (list_empty(&log->synclist))
> - log->sync = log->lsn;
> - else {
> - lp = list_entry(log->synclist.next,
> - struct logsyncblk, synclist);
> - log->sync = lp->lsn;
> - }
> + lp = list_last_entry_or_null(&log->synclist, struct logsyncblk,
> + synclist);
Here it could be simplified via list_first_entry_or_null(), my apology for this mistake.
> + log->sync = lp ? lp->lsn : log->lsn;
> LOGSYNC_UNLOCK(log, flags);
>
> }
>

Thanks,
-Jeff


\
 
 \ /
  Last update: 2013-11-15 06:01    [W:0.124 / U:0.028 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site