lkml.org 
[lkml]   [2013]   [Oct]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [tpmdd-devel] [PATCH 02/13] tpm atmel: Call request_region with the correct base
On 10/02/2013 11:36 PM, Jason Gunthorpe wrote:
> On Wed, Oct 02, 2013 at 07:11:14PM -0500, Ashley D Lai wrote:
>
>>> I somewhat have the feeling that we should maybe begin to deprecate
>>> the vendor specific 1.1 tpms...
>
>> I agree. If we have a machine to test and it fails then we know we don't
>> have a user for this.
>
> Is this driver is only used on IBM systems? If so, will IBM provide
> support for those systems on RHEL7? If not the driver can probably
> safely be dropped.
>
> The trouble with these old drivers is that they don't follow modern
> conventions (there are several little bugs at least) and nobody can
> test them to safely fix them.
>
> If you do find hardware, we can at least take a solid run at sprucing
> up the testable drivers which should give them more life..
>
> Jason

We don't have any plans to support 1.1 tpms in any new major
distribution releases. I am in support of deprecating 1.1 tpms and just
supporting 1.2 and 2.0 going forward.

This is the direction we are taking with TrouSerS as well for what it's
worth. So that's at least one major user you won't see complain about
missing tpm 1.1 support.

-Joel



\
 
 \ /
  Last update: 2013-10-04 19:41    [W:0.067 / U:37.956 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site