lkml.org 
[lkml]   [2013]   [Oct]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH -tip 1/2] [BUGFIX] kprobes/x86: Prohibit probing on debug_stack_*

* Masami Hiramatsu <masami.hiramatsu.pt@hitachi.com> wrote:

> -int is_debug_stack(unsigned long addr)
> +int __kprobes is_debug_stack(unsigned long addr)

_Please_ add a __noprobes method, for new annotations.

Naming it '__kprobes' is actively confusing, as it suggests that the
function is somehow positively involved with kprobes support.
Instead it should the noinline/notrace pattern.

I complained about this before and not much happened on this front.
We might not want to convert the whole kernel straight away, but for
_new_ annotations there's no excuse not to name them properly. Lets
phase out __kprobes, and use __noprobe from now on, okay?

Thanks,

Ingo


\
 
 \ /
  Last update: 2013-10-31 10:01    [W:0.069 / U:0.132 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site