lkml.org 
[lkml]   [2013]   [Oct]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 5/9][v5] powerpc: implement is_instr_load_store().
    Michael Ellerman [michael@ellerman.id.au] wrote:
    | On Tue, Oct 01, 2013 at 05:15:06PM -0700, Sukadev Bhattiprolu wrote:
    | > Implement is_instr_load_store() to detect whether a given instruction
    | > is one of the fixed-point or floating-point load/store instructions.
    | > This function will be used in a follow-on patch to save memory hierarchy
    | > information of the load/store.
    |
    | The search over the array is a bit of a pity, especially as the worst
    | case penalises you when you haven't hit a load/store.

    Agree. Will try this out. This is certainly more efficient.

    |
    | I think we can do better. If you look at the opcode maps, and in
    | particular the extended table for opcode 31, you'll see there's a
    | reasonable amount of structure.
    |
    | The following is only valid for arch 2.06, ie. it will classify reserved
    | opcodes as being load/store, but I think that's fine for the moment. If
    | we need to use it somewhere in future we can update it. But we should
    | add a big comment saying it's only valid in that case.
    |
    | Anyway, I think the following logic is all we need for opcode 31:
    |
    | bool is_load_store(int ext_opcode)

    how about I call this is_load_store_2_06() and add a comment. Horrible
    but minimizes chance of misuse.

    | {
    | upper = ext_opcode >> 5;
    | lower = ext_opcode & 0x1f;
    |
    | /* Short circuit as many misses as we can */
    | if (lower < 3 || lower > 23)
    | return false;
    |
    | if (lower == 3)
    | if (upper >= 16)
    | return true;
    |
    | return false;
    |
    | if (lower == 6)
    | if (upper <= 1)
    | return true;
    | return false;
    |
    | if (lower == 7 || lower == 12)
    | return true;
    |
    | if (lower >= 20) /* && lower <= 23 (implicit) */
    | return true;
    |
    | return false;
    | }
    |
    |
    | Which is not pretty, but I think it's preferable to the full search over the
    | array.
    |
    | cheers



    \
     
     \ /
      Last update: 2013-10-03 21:21    [W:4.084 / U:0.008 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site