lkml.org 
[lkml]   [2013]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [BUG] perf timechart segfault
On Wed, Oct 02, 2013 at 04:36:45PM +0530, Ramkumar Ramachandra wrote:
> Hi,
>
> I tried using the `perf timechart` command after a `sudo perf
> timechart record -- git status`, and it segfaulted. Backtrace follows:
>
> Program received signal SIGSEGV, Segmentation fault.
> 0x0000000000000000 in ?? ()
> (gdb) bt
> #0 0x0000000000000000 in ?? ()
> #1 0x000000000047d728 in perf_session_deliver_event
> (session=session@entry=0x8ea450, event=event@entry=0x7ffff7f13f98,
> sample=sample@entry=0x7fffffffd530,
> tool=tool@entry=0x7fffffffd7a0, file_offset=file_offset@entry=8088)
> at util/session.c:1006
> #2 0x000000000047faec in perf_session__process_event
> (file_offset=8088, tool=0x7fffffffd7a0, event=0x7ffff7f13f98,
> session=0x8ea450) at util/session.c:1098
> #3 __perf_session__process_events (session=session@entry=0x8ea450,
> data_offset=<optimized out>,
> data_size=<optimized out>, file_size=635384,
> tool=tool@entry=0x7fffffffd7a0) at util/session.c:1360
> #4 0x000000000047ff81 in perf_session__process_events
> (self=self@entry=0x8ea450, tool=tool@entry=0x7fffffffd7a0)
> at util/session.c:1403
> #5 0x000000000042f12a in __cmd_timechart (output_name=0x4ee399
> "output.svg") at builtin-timechart.c:1009
> #6 cmd_timechart (argc=0, argv=0x7fffffffdf20, prefix=<optimized
> out>) at builtin-timechart.c:1116
> #7 0x0000000000419925 in run_builtin (p=p@entry=0x725f90
> <commands+240>, argc=argc@entry=1,
> argv=argv@entry=0x7fffffffdf20) at perf.c:319
> #8 0x0000000000419199 in handle_internal_command
> (argv=0x7fffffffdf20, argc=1) at perf.c:376
> #9 run_argv (argv=0x7fffffffdd20, argcp=0x7fffffffdd2c) at perf.c:420
> #10 main (argc=1, argv=0x7fffffffdf20) at perf.c:521
>
> I compiled it with EXTRA_CFLAGS="-O0 -g", so all the debugging symbols
> should be available. Not sure what's going on, or why I needed sudo to
> record data in the first place.

hi,
what perf version are you running? I can't hit the issue
and also the file lines in backtrace indicate it's not
current one.

thanks,
jirka


\
 
 \ /
  Last update: 2013-10-02 13:41    [W:0.101 / U:1.256 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site