lkml.org 
[lkml]   [2013]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH v4 1/4] drivers: usb: phy: add a new driver for usb part of control module
Hi,

On Fri, Jan 25, 2013 at 12:29:43PM +0000, Mark Rutland wrote:
> > > > + depending upon omap4 or omap5.
> > > > + - reg-names: The names of the register addresses corresponding to the registers
> > > > + filled in "reg".
> > > > + - ti,type: This is used to differentiate whether the control module has
> > > > + usb mailbox or usb3 phy power. omap4 has usb mailbox in control module to
> > > > + notify events to the musb core and omap5 has usb3 phy power register to
> > > > + power on usb3 phy. Should be "1" if it has mailbox and "2" if it has usb3
> > > > + phy power.
> > >
> > > Why not make this a string property, perhaps values "mailbox" or "register"?
> >
> > NAK.
>
> Can I ask what your objection to using a string property is?
>
> As far as I can see, "ti,type" is only used by this driver, so there's no
> common convention to stick to. Using a string makes the binding easier for
> humans to read, and thus harder to mess up in a dts, and it decouples the
> binding from kernel-side constants.

IIRC there is some work going on to add #define-like support for DT,
which would allow us to match against integers while still having
meaningful symbolic representations.

--
balbi
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2013-01-25 16:42    [W:0.064 / U:11.316 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site