lkml.org 
[lkml]   [2012]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: qemu-kvm loops after kernel udpate
On 09/11/2012 10:41 PM, Jiri Slaby wrote:
> On 09/11/2012 09:03 PM, Marcelo Tosatti wrote:
>> On Tue, Sep 11, 2012 at 08:11:36PM +0200, Jiri Slaby wrote:
>>> Hi,
>>>
>>> it looks like an update from next-20120824 to next-20120910 makes kvm
>>> defunct. When I try to run qemu, it loops forever without printing
>>> anything on the monitor.
>>>
>>> -no-kvm makes it indeed work.
>>>
>>> Cmdline I use:
>>> qemu-kvm -k en-us -usbdevice tablet -balloon virtio -hda IMAGE -smp 2 -m
>>> 1000M -net user -net nic,model=e1000 -usb -serial pty
>>>
>>> Before I start investigating further, like biscection, is this a known
>>> issue already and fix available somewhere?
>>
>> Its not a known issue. 'info registers' (for both vcpus) and
>> 'x /20i $eip' might help track it down.
>
> I don't think it's in a state with something loaded.
>
> (qemu) cpu 0
> (qemu) info registers
> EAX=00000000 EBX=00000000 ECX=00000000 EDX=00000623
> ESI=00000000 EDI=00000000 EBP=00000000 ESP=00000000
> EIP=0000fff0 EFL=00010002 [-------] CPL=3 II=0 A20=1 SMM=0 HLT=0
> ES =0000 00000000 0000ffff 00009300
> CS =f000 000f0000 0000ffff 0000f300

This is before the first instruction is executed.

You're on an Intel host, yes? Please provide the output of vmxcap
(http://goo.gl/c5lUO), and a snapshot of kvm_stat while the guest is hung.


--
error compiling committee.c: too many arguments to function


\
 
 \ /
  Last update: 2012-09-12 10:41    [W:0.093 / U:1.952 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site