[lkml]   [2012]   [Sep]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH] allow gpiolib to be a module
On Wed, Sep 12, 2012 at 9:43 AM, Jan Beulich <> wrote:

>> I can't parse this, sorry the gpio subsystem maintainer is too bad coder.
>> What about something more readable?
>> int ret;
>> ret = gpiolib_sysfs_init();
>> if (ret)
>> return ret;
>> return gpiolib_debugfs_init();
>> I know it doesn't look as cool but it's easier for me to understand.
> Okay, since you're the second one to complain despite there
> being other uses of the construct in the same source file, I'll
> replace it, ...

Sorry about that, but two wrongs does not make one right.
I'd be happy if you patch the other constructs too...

Linus Walleij

 \ /
  Last update: 2012-09-12 18:41    [W:0.085 / U:7.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site