[lkml]   [2012]   [Aug]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [patch net-next 01/16] net: introduce upper device lists
Le 13/08/2012 19:31, Jiri Pirko a écrit :
> Mon, Aug 13, 2012 at 07:04:11PM CEST, wrote:

>>> +struct netdev_upper {
>>> + struct net_device *dev;
>>> + bool unique;
>> This needs a better name. It doesn't really have anything to do with
>> uniqueness and doesn't ensure exclusivity. I think that it would be
>> fine to keep the 'master' term.
> Hmm. I admit that "unique" I do not like too much as well. But "master"
> I like even less.
> This flag should ensure exclusivity. Only one upper device with this
> flag can be present at a time.

Well, can't we simply call it "upper_device"?

And as we only have a single field, this is exclusive by design.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2012-08-16 00:43    [W:0.047 / U:1.472 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site