Messages in this thread |  | | Date | Mon, 30 Jul 2012 19:07:20 -0700 (PDT) | | From | David Rientjes <> | | Subject | Re: [PATCH TRIVIAL] mm: Fix build warning in kmem_cache_create() |
| |
On Mon, 30 Jul 2012, Pekka Enberg wrote:
> > -Wunused-label is overridden in gcc for a label that is conditionally > > referenced by using __maybe_unused in the kernel. I'm not sure what's so > > obscure about > > > > out: __maybe_unused > > > > Are label attributes really that obsecure? > > I think they are. > > The real problem, however, is that label attributes would just paper > over the badly thought out control flow in the function and not make the > code any better or easier to read. >
So much for compromise, I thought we had agreed that at least some of the checks for !name, in_interrupt() or bad size values should be moved out from under the #ifdef CONFIG_DEBUG_VM, but this wasn't done. This discussion would be irrelevent if we actually did what we talked about.
|  |