lkml.org 
[lkml]   [2012]   [Jul]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [vmw_vmci 11/11] Apply the header code to make VMCI build
> > > +
> > > +#define CAN_BLOCK(_f) (!((_f) & VMCI_QPFLAG_NONBLOCK))
> > > +#define QP_PINNED(_f) ((_f) & VMCI_QPFLAG_PINNED)
> >
> > Looks like poor obscufation.
> > Use a statis inline function if you need a helper for this.
>
> These definitions are intended more as a helper to make reading the code easier. IMHO ts a lot easier to read
>
> if (CAN_BLOCK(flags))
>
> compared to
>
> if (!(flags & VMCI_QPFLAG_NONBLOCK))
>
> Wouldn't you agree? I'm not sure something this simple warrants a static inline
> function but I don't see any harm in converting it over to that.

I would put it the other way around. I cannot see that such simple stuff warrants a #define.
A static inline is (almost) always preferable to hide code in a macro.

For once you get better type-checks.
And semantics are also much simpler. With a macro you can do so many silly things.

Sam


\
 
 \ /
  Last update: 2012-07-27 22:41    [W:0.120 / U:5.124 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site