lkml.org 
[lkml]   [2012]   [Jul]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 3/4] uprobes: rename vma_address() and make it return "unsigned long"
* Oleg Nesterov <oleg@redhat.com> [2012-07-26 12:28:12]:

> On 07/26, Srikar Dronamraju wrote:
> >
> > * Oleg Nesterov <oleg@redhat.com> [2012-07-12 19:10:22]:
> >
> > > 1. vma_address() returns loff_t, this looks confusing and this is
> > > unnecessary after the previous change. Make it return "ulong",
> > > all callers truncate the result anyway.
> > >
> > > 2. Its name conflicts with mm/rmap.c:vma_address(), rename it to
> > > offset_to_vaddr(), this matches vaddr_to_offset().
> > >
> > > Signed-off-by: Oleg Nesterov <oleg@redhat.com>
> >
> > Acked-by: Srikar Dronamraju <srikar@linux.vnet.ibm.com>
>
> Thanks.
>
> Could you please ack v2 below?
>
> I forgot to update "loff_t vaddr" in mmap/munmap. IOW, this is the
> same patch plus
>
> - loff_t vaddr = offset_to_vaddr(...);
> + unsigned long vaddr = offset_to_vaddr(...);
>
> in uprobe_mmap/munmap.
>

Acked-by: Srikar Dronamraju <srikar@linux.vnet.ibm.com>

> In fact I was going to do this in
> "uprobes: teach build_probe_list() to consider the range" but
> forgot as well.
>
> Oleg.
>
> --- a/kernel/events/uprobes.c
> +++ b/kernel/events/uprobes.c
> @@ -112,14 +112,9 @@ static bool valid_vma(struct vm_area_struct *vma, bool is_register)
> return false;
> }
>
> -static loff_t vma_address(struct vm_area_struct *vma, loff_t offset)
> +static unsigned long offset_to_vaddr(struct vm_area_struct *vma, loff_t offset)
> {
> - loff_t vaddr;
> -
> - vaddr = vma->vm_start + offset;
> - vaddr -= (loff_t)vma->vm_pgoff << PAGE_SHIFT;
> -
> - return vaddr;
> + return vma->vm_start + offset - ((loff_t)vma->vm_pgoff << PAGE_SHIFT);
> }
>
> static loff_t vaddr_to_offset(struct vm_area_struct *vma, unsigned long vaddr)
> @@ -775,7 +770,7 @@ build_map_info(struct address_space *mapping, loff_t offset, bool is_register)
> curr = info;
>
> info->mm = vma->vm_mm;
> - info->vaddr = vma_address(vma, offset);
> + info->vaddr = offset_to_vaddr(vma, offset);
> }
> mutex_unlock(&mapping->i_mmap_mutex);
>
> @@ -1042,7 +1037,7 @@ int uprobe_mmap(struct vm_area_struct *vma)
>
> list_for_each_entry_safe(uprobe, u, &tmp_list, pending_list) {
> if (!ret) {
> - loff_t vaddr = vma_address(vma, uprobe->offset);
> + unsigned long vaddr = offset_to_vaddr(vma, uprobe->offset);
>
> ret = install_breakpoint(uprobe, vma->vm_mm, vma, vaddr);
> /*
> @@ -1103,7 +1098,7 @@ void uprobe_munmap(struct vm_area_struct *vma, unsigned long start, unsigned lon
> build_probe_list(inode, vma, start, end, &tmp_list);
>
> list_for_each_entry_safe(uprobe, u, &tmp_list, pending_list) {
> - loff_t vaddr = vma_address(vma, uprobe->offset);
> + unsigned long vaddr = offset_to_vaddr(vma, uprobe->offset);
> /*
> * An unregister could have removed the probe before
> * unmap. So check before we decrement the count.
>



\
 
 \ /
  Last update: 2012-07-27 09:01    [W:0.134 / U:0.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site