lkml.org 
[lkml]   [2012]   [Jul]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [BUG] Problem with commit cf03c5dac83609f09d9f0e9fa3c09d86daed614d
Date
Seth Forshee <seth.forshee@canonical.com> writes:

> On Thu, Jul 26, 2012 at 03:28:44PM +0200, Dirk Gouders wrote:
>> Hi Seth,
>>
>> today, I noticed a problem with the current kernel
>> (3.5.0-04773-gbdc0077): my laptop hangs during boot -- the last message
>> on the console is printed just before invoking `udevadm trigger'.
>>
>> I bisected the problem and ended at commit
>> cf03c5dac83609f09d9f0e9fa3c09d86daed614d (brcm80211: smac: inform
>> mac80211 of the X2 regulatory domain). However, I'm not sure that this
>> commit really is the reason for my problems, because the behaviour is a
>> bit different: at that state the machine not just hangs but the console
>> shows a trace which I append to the end of this mail -- but the trace
>> happens at the same state during the boot process.
>
> Hi Dirk,
>
> The NULL pointer dereference in wlc_phy_chanspec_band_validch is already
> fixed in edc7651f3a4ffa7fca37d92401562694121512ad. There was also
> another related crash that appeared after the introduction of 802.11ad
> support that's fixed in 32c336a5dfd16b4645c8a0dbc534efd02f079e02.
>
> So in all likelihood whatever problem your seeing in current -git is a
> different issue. One easy way to test this would be to prevent the
> brcmsmac module from loading and verify that you still get the hang,
> then rerun the bisection that way to keep those bugs from affecting your
> results.

Hi Seth,

thanks for your reply and sorry for the noise.

I followed your advice and tried to boot with the WLAN interface turned
off, and the problem still exists. I'll start a new bisect session,
probably with one of the commits you mentioned as the first good commit.

Best regards,

Dirk


\
 
 \ /
  Last update: 2012-07-26 17:41    [W:0.087 / U:0.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site