lkml.org 
[lkml]   [2012]   [Jun]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH] perf/x86: check ucode before disabling PEBS on SandyBridge
On 06/08/2012 07:17 AM, Borislav Petkov wrote:
> On Fri, Jun 08, 2012 at 04:03:38PM +0200, Stephane Eranian wrote:
>> On Fri, Jun 8, 2012 at 3:59 PM, Peter Zijlstra <peterz@infradead.org> wrote:
>>> On Fri, 2012-06-08 at 15:51 +0200, Borislav Petkov wrote:
>>>> Provided, of course, newer microcode versions means a
>>>> higher version number.
>>>
>>> Fair enough, I assumed this.. is this true?
>>>
>> I would think so, otherwise it gets even messier!
>
> Need to get Intel folk to say something here, hpa?
>

There are some exceptions; but it's good enough for this purpose.

The main exception is that not every revision may be installable on
every CPU; so you might have 0x20, 0x24, 0x28 on one CPU and 0x22, 0x26,
0x2a on another; this only requires caution when you set your bracket
values.

-hpa

--
H. Peter Anvin, Intel Open Source Technology Center
I work for Intel. I don't speak on their behalf.



\
 
 \ /
  Last update: 2012-06-08 18:41    [from the cache]
©2003-2011 Jasper Spaans