lkml.org 
[lkml]   [2012]   [Jun]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: [PATCH 01/22 v4] Input: atmel_mxt_ts - set phys to i2c client adapter name
From
[oops. sorry for duplicate send... resending in plaintext]

Would it more sense to more completely describe the bus type, adapter,
and address in this case, rather than using the client->adapter->name?

Just to give an example from our system, client->adapter->name is
"i915 gmbus panel", so your suggestion would be "i915 gmbus
panel/input0"

How about this instead :
i2c-2-004a/input0

This seems to me more consistent with what is done with USB input
devices, which show a phys field like this :
usb-00:01.2-2.2/input0

Benson

On Mon, Jun 25, 2012 at 6:27 PM, Dmitry Torokhov
<dmitry.torokhov@gmail.com> wrote:
>
> On Mon, Jun 25, 2012 at 05:58:46PM +0800, Daniel Kurtz wrote:
> > On Mon, Jun 25, 2012 at 4:15 PM, Henrik Rydberg <rydberg@euromail.se>
> > wrote:
> > >
> > > On Thu, Jun 21, 2012 at 01:41:07AM -0700, Dmitry Torokhov wrote:
> > > > On Mon, Jun 18, 2012 at 12:08:21PM +0800, Daniel Kurtz wrote:
> > > > > This allows userspace to more easily distinguish which bus a
> > > > > particular
> > > > > atmel_mxt_ts device is attached to.
> > > > >
> > > > > Signed-off-by: Daniel Kurtz <djkurtz@chromium.org>
> > > > > ---
> > > > >  drivers/input/touchscreen/atmel_mxt_ts.c |    1 +
> > > > >  1 files changed, 1 insertions(+), 0 deletions(-)
> > > > >
> > > > > diff --git a/drivers/input/touchscreen/atmel_mxt_ts.c
> > > > > b/drivers/input/touchscreen/atmel_mxt_ts.c
> > > > > index 42e6450..eda9eed 100644
> > > > > --- a/drivers/input/touchscreen/atmel_mxt_ts.c
> > > > > +++ b/drivers/input/touchscreen/atmel_mxt_ts.c
> > > > > @@ -1106,6 +1106,7 @@ static int __devinit mxt_probe(struct
> > > > > i2c_client
> > > > > *client,
> > > > >     }
> > > > >
> > > > >     input_dev->name = "Atmel maXTouch Touchscreen";
> > > > > +   input_dev->phys = client->adapter->name;
> > > >
> > > > Normally we set phys to 'xxx/input0' nstead of just the adaptor
> > > > name.
> > >
> > > Daniel, will we be seeing another version of this patch?
> >
> > Yes.  Any guidance on "xxx" ?  atmel_mxt_ts?
>
> What you have before (client->adapter->name) + "/input0" shoudl work
> splendidly.
>
> Thanks.
>
> --
> Dmitry




--
Benson Leung
Software Engineer, Chrom* OS
bleung@chromium.org
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2012-06-27 03:21    [W:0.078 / U:0.048 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site