[lkml]   [2012]   [May]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Linux Support for Thunderbolt using Apple Monitor
Greg, Nico,

Thanks Greg for giving us some attention. I went ahead and collected a
number of information that could be useful to track down our hotplug issue.

1) Coldplug: Booting with the thunderbolt display attached. This works.
Several devices (additional to what I get without the display attached)
are listed. Here is the relevant info: -> kernel.log -> lspci and lspci -vv
full config @ -> message when
disconnecting (pciehp loaded just before)

note that an attempt to reconnect leads to the same issue as described
before, i.e. nothing happens.

2) Booting with the display/device not plugged, just for reference:

3) Again, I have tried to load pciehp and acpiphp with both EFI boot and
BIOS emulation boot:
- pciehp loads ok but as I said earlier, no message whatsoever in
everything.log when I try to connect the thunderbolt display
- acpiphp: I was wrong yesterday. In fact, trying to load acpiphp gives
me a message:
[root@poliahu thunderbolt]# modprobe acpiphp
ERROR: could not insert 'acpiphp': No such device

Not sure what to make of it. I have tried to also load acpiphp after a
coldplug boot; same error message.

I've read somewhere that this error message may mean that the h/w
doesn't support hotplugging. However, I think the coldplug lspci -vv
above tells us the h/w does support pcie hotplug: all the pci bridges
appear to have D3hot+ capability (and it certainly does, as this works
under osx on the same machine).

Any suggestion are welcome! Thanks.

 \ /
  Last update: 2012-05-04 07:04    [W:0.157 / U:0.688 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site