lkml.org 
[lkml]   [2012]   [Apr]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: linux-next: Tree for Apr 19 (zcache)
On Fri, Apr 20, 2012 at 02:06:41PM -0500, Seth Jennings wrote:
> On 04/20/2012 11:37 AM, Konrad Rzeszutek Wilk wrote:
> > On Thu, Apr 19, 2012 at 11:36:26PM -0500, Seth Jennings wrote:
> >> One fix is this:
> >>
> >> diff --git a/drivers/staging/zcache/Kconfig b/drivers/staging/zcache/Kconfig
> >> index 3ed2c8f..7048e01 100644
> >> --- a/drivers/staging/zcache/Kconfig
> >> +++ b/drivers/staging/zcache/Kconfig
> >> @@ -2,7 +2,7 @@ config ZCACHE
> >> bool "Dynamic compression of swap pages and clean pagecache pages"
> >> # X86 dependency is because zsmalloc uses non-portable pte/tlb
> >> # functions
> >> - depends on (CLEANCACHE || FRONTSWAP) && CRYPTO && X86
> >> + depends on (CLEANCACHE || FRONTSWAP) && CRYPTO=y && X86
> >> select ZSMALLOC
> >> select CRYPTO_LZO
> >> default n
> >>
> >> I think this is the best way since ZCACHE is a bool and CRYPTO is the only
> >> one of the dependencies that is a tristate. This forces both ZSMALLOC and
> >> CRYPTO_LZO to be builtin if ZCACHE is selected.
> >>
> >> Any other suggestions?
> >
> > Could you do:
> >
> > default y if (CRYPTO=y || ZSMALLOC=m)
> > default m if (CRYPTO=m || ZSMALLOC=y)
>
> ZCACHE is a bool and can't be built as a module.

Duh!
>
> The requirement is the if ZCACHE=y, then ZSMALLOC and
> CRYPTO must also =y.

OK, your patch makes sense then. Can you repost it please with
Greg KH on it so he can add it in the staging tree?


\
 
 \ /
  Last update: 2012-04-24 03:15    [W:0.032 / U:23.252 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site