lkml.org 
[lkml]   [2012]   [Apr]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    Patch in this message
    /
    Date
    From
    Subject[ 73/75] drm/radeon/kms: fix the regression of DVI connector check
    3.3-stable review patch.  If anyone has any objections, please let me know.

    ------------------

    From: Takashi Iwai <tiwai@suse.de>

    commit e36325071832f1ba96ac54fb8ba1459f08b05dd8 upstream.

    The check of the encoder type in the commit [e00e8b5e: drm/radeon/kms:
    fix analog load detection on DVI-I connectors] is obviously wrong, and
    it's the culprit of the regression on my workstation with DVI-analog
    connection resulting in the blank output.

    Fixed the typo now.

    Signed-off-by: Takashi Iwai <tiwai@suse.de>
    Reviewed-by: Alex Deucher <alexander.deucher@amd.com>
    Signed-off-by: Dave Airlie <airlied@redhat.com>
    Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>

    ---
    drivers/gpu/drm/radeon/radeon_connectors.c | 2 +-
    1 file changed, 1 insertion(+), 1 deletion(-)

    --- a/drivers/gpu/drm/radeon/radeon_connectors.c
    +++ b/drivers/gpu/drm/radeon/radeon_connectors.c
    @@ -946,7 +946,7 @@ radeon_dvi_detect(struct drm_connector *

    encoder = obj_to_encoder(obj);

    - if (encoder->encoder_type != DRM_MODE_ENCODER_DAC ||
    + if (encoder->encoder_type != DRM_MODE_ENCODER_DAC &&
    encoder->encoder_type != DRM_MODE_ENCODER_TVDAC)
    continue;




    \
     
     \ /
      Last update: 2012-04-19 23:55    [W:0.023 / U:0.272 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site