[lkml]   [2012]   [Mar]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH v2 0/3] ahci: fix boot/resume COMRESET failures
On Sun, Mar 4, 2012 at 6:58 PM, Lin Ming <> wrote:
> On Fri, Mar 2, 2012 at 9:16 PM, cwillu <> wrote:
>> On Tue, Feb 21, 2012 at 12:38 PM, Brian Norris
>> <> wrote:
>>> This series addresses regression problems with
>>>    commit 7faa33da9b7add01db9f1ad92c6a5d9145e940a7
>>>    ahci: start engine only during soft/hard resets
>> I just spent the better part of last night tracking down the specific
>> sources of the log entry I get when I disconnect my e-sata drive; once
>> it disconnects, the port is dead until I reboot; no combination of
>> anything I've been able to poke at in /sys or elsewhere gets it live
>> again.  This starts with 3.3rc1, and turns out to still work fine in
>> 3.2.1. Any chance it's related?
>> 3.3rc5, immediately after the unplug:
> Hi,
> I tested on my machine and it's fixed by below patch.
> Would you please also try it?

Building it now, and will be able to test in about 5 hours.

After looking at the thread, I spent another couple hours on poking
/sys, and did get the port to come back up and find the drive with the

echo on > /sys/devices/pci0000:00/0000:00:1f.2/ata5/power/control
echo on > /sys/devices/pci0000:00/0000:00:1f.2/ata5/host4/power/control
echo '- - -' > /sys/devices/pci0000:00/0000:00:1f.2/ata5/host4/scsi_host/host4/scan
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at
 \ /
  Last update: 2012-03-05 06:15    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean