[lkml]   [2012]   [Mar]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 8/9] vfs: split __lookup_hash
On Tue, Mar 06, 2012 at 01:56:40PM +0100, Miklos Szeredi wrote:
> From: Miklos Szeredi <>
> Split __lookup_hash into two component functions:
> lookup_dcache - tries cached lookup, returns whether real lookup is needed
> lookup_real - calls i_op->lookup
> This eliminates code duplication between d_alloc_and_lookup() and
> d_inode_lookup().

The return value from lookup_dcache is a bit confusing. What about
returning the need_lookup flag, and passing the dentry as a parameter,
that way the callers would do the more obvious:

if (lookup_dcache(name, base, nd, &dentry))
return dentry;

instead of having to check two conditions.

 \ /
  Last update: 2012-03-20 17:41    [W:0.085 / U:24.204 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site