lkml.org 
[lkml]   [2012]   [Mar]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: ath: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x02000020 DMADBG_7=0x00008040
    On 03/20/2012 01:29 AM, Sujith Manoharan wrote:
    > Justin P. Mattock wrote:
    >> yeah this works:
    >>
    >> eading symbols from
    >> /home/kernel/linux-next/drivers/net/wireless/ath/ath9k/ath9k.o...done.
    >> (gdb) l *(ath_tx_start+0x284)
    >> 0xcad4 is in ath_tx_start (drivers/net/wireless/ath/ath9k/xmit.c:1878).
    >> 1873 ieee80211_is_data_qos(hdr->frame_control)) {
    >> 1874 tidno = ieee80211_get_qos_ctl(hdr)[0]&
    >> 1875 IEEE80211_QOS_CTL_TID_MASK;
    >> 1876 tid = ATH_AN_2_TID(txctl->an, tidno);
    >> 1877
    >> 1878 WARN_ON(tid->ac->txq != txctl->txq);
    >> 1879 }
    >> 1880
    >> 1881 if ((tx_info->flags& IEEE80211_TX_CTL_AMPDU)&& tid) {
    >> 1882 /*
    >> (gdb)
    >
    > Can you try this patch ?
    >
    > From: Sujith Manoharan<c_manoha@qca.qualcomm.com>
    > Date: Tue, 20 Mar 2012 13:51:26 +0530
    > Subject: [PATCH] ath9k: Use HW HT capabilites properly
    >
    > The commit "ath9k: Remove aggregation flags" changed how
    > nodes were being initialized. Use the HW HT cap bits
    > to initialize/de-initialize nodes, else we would be
    > accessing an uninitialized entry during a suspend/resume cycle,
    > resulting in a panic.
    >
    > Reported-by: Justin P. Mattock<justinmattock@gmail.com>
    > Signed-off-by: Sujith Manoharan<c_manoha@qca.qualcomm.com>
    > ---
    > drivers/net/wireless/ath/ath9k/main.c | 4 ++--
    > 1 file changed, 2 insertions(+), 2 deletions(-)
    >
    > diff --git a/drivers/net/wireless/ath/ath9k/main.c b/drivers/net/wireless/ath/ath9k/main.c
    > index 3879485..215eb25 100644
    > --- a/drivers/net/wireless/ath/ath9k/main.c
    > +++ b/drivers/net/wireless/ath/ath9k/main.c
    > @@ -640,7 +640,7 @@ static void ath_node_attach(struct ath_softc *sc, struct ieee80211_sta *sta,
    > an->sta = sta;
    > an->vif = vif;
    >
    > - if (sta->ht_cap.ht_supported) {
    > + if (sc->sc_ah->caps.hw_caps& ATH9K_HW_CAP_HT) {
    > ath_tx_node_init(sc, an);
    > an->maxampdu = 1<< (IEEE80211_HT_MAX_AMPDU_FACTOR +
    > sta->ht_cap.ampdu_factor);
    > @@ -659,7 +659,7 @@ static void ath_node_detach(struct ath_softc *sc, struct ieee80211_sta *sta)
    > an->sta = NULL;
    > #endif
    >
    > - if (sta->ht_cap.ht_supported)
    > + if (sc->sc_ah->caps.hw_caps& ATH9K_HW_CAP_HT)
    > ath_tx_node_cleanup(sc, an);
    > }
    >


    alright!

    both mohammed and sujith Thank you for the patches for this issue!
    I really appreciate this..

    I went and applied the debug printk and added ath_node_attach as well to
    my linux-next clone, will run for a few days to see if I get anything..
    full dmesg is here..: http://fpaste.org/jHSX/

    Justin P. Mattock



    \
     
     \ /
      Last update: 2012-03-20 15:21    [W:0.038 / U:60.188 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site