lkml.org 
[lkml]   [2012]   [Feb]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [PATCH 6/6] pagemap: introduce data structure for pagemap entry
On Thu, 9 Feb 2012 16:27:41 -0800
Andrew Morton <akpm@linux-foundation.org> wrote:

> On Wed, 8 Feb 2012 10:51:42 -0500
> Naoya Horiguchi <n-horiguchi@ah.jp.nec.com> wrote:
>
> > Currently a local variable of pagemap entry in pagemap_pte_range()
> > is named pfn and typed with u64, but it's not correct (pfn should
> > be unsigned long.)
> > This patch introduces special type for pagemap entry and replace
> > code with it.
> >
> > Signed-off-by: Naoya Horiguchi <n-horiguchi@ah.jp.nec.com>
> > Cc: Andrew Morton <akpm@linux-foundation.org>
> >
> > Changes since v4:
> > - Rename pme_t to pagemap_entry_t
>
> hm. Why this change? I'd have thought that this should be called
> pme_t. And defined in or under pgtable.h, rather than being private to
> fs/proc/task_mmu.c.
>

Ah, he changed the name because I complained "pme_t seems a new page table entry
type.."

Regards,
-Kame



\
 
 \ /
  Last update: 2012-02-10 02:03    [W:0.057 / U:2.432 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site