lkml.org 
[lkml]   [2012]   [Feb]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs

    * Jason Baron <jbaron@redhat.com> wrote:

    > On Fri, Feb 24, 2012 at 10:08:11AM +0100, Ingo Molnar wrote:
    > > * Jason Baron <jbaron@redhat.com> wrote:
    > >
    > > > On Thu, Feb 23, 2012 at 06:18:42PM -0500, Mathieu Desnoyers wrote:
    > > > > * Ingo Molnar (mingo@elte.hu) wrote:
    > > > > >
    > > > > > * Ingo Molnar <mingo@elte.hu> wrote:
    > > > > >
    > > > > > > So, a modified scheme would be:
    > > > > > >
    > > > > > > #include <linux/static_key.h>
    > > > > > >
    > > > > > > struct static_key key = STATIC_KEY_INIT_TRUE;
    > > > > > >
    > > > > > > if (static_key_false(&key))
    > > > > > > do unlikely code
    > > > > > > else
    > > > > > > do likely code
    > > > > > >
    > > > > > > Or:
    > > > > > >
    > > > > > > if (static_key_true(&key))
    > > > > > > do likely code
    > > > > > > else
    > > > > > > do unlikely code
    > > > > > >
    > > > > > > The static key is modified via:
    > > > > > >
    > > > > > > static_key_slow_inc(&key);
    > > > > > > ...
    > > > > > > static_key_slow_dec(&key);
    > > > > > >
    > > > > > > Is that API fine? I'll rework the series to such an effect if
    > > > > > > everyone agrees.
    > > > > >
    > > > > > I.e. something like the patch below on top of
    > > > > > tip:perf/jump-labels.
    > > > > >
    > > > > > Untested - will test it and will refactor the series if
    > > > > > everyone's happy.
    > > > >
    > > > > Hi Ingo,
    > > > >
    > > > > Reading your documentation updates makes me realise that adding the
    > > > > "inline" keyword in there would make the whole thing even clearer:
    > > > >
    > > > > struct static_key key = STATIC_KEY_INLINE_TRUE_INIT;
    > > > > struct static_key key = STATIC_KEY_INLINE_FALSE_INIT;
    > > > >
    > > > > static_key_inline_true() / static_key_inline_false()
    > > > >
    > > > > to show that the "true/false" in there does not mean that the key will
    > > > > always be true or false (the key value can indeed by changed by calling
    > > > > static_key_slow_inc/dec), but that the inlined path is either the true
    > > > > of false branch.
    > > > >
    > > >
    > > > Also, as part of the API, there is a test to check the branch
    > > > direction - which was 'jump_label_true(key)', but is now also
    > > > 'static_key_true(key)', [...]
    > >
    > > Yeah, there is such an overlap - I've renamed it to
    > > static_key_enabled(), which makes sense anyway as the original
    > > was jump_label_enabled()..
    > >
    > > Btw., shouldnt it be an inline function? Currently it's:
    > >
    >
    > Yes. I've had thought that too. In fact, it is already 'static
    > inline' for the !JUMP_LABEL case. So we can probably just
    > remove the function from the .c and move the 'static inline'
    > such that its defined for all cases.

    Yep. Mind sending a patch for that, against latest -tip?

    Thanks,

    Ingo


    \
     
     \ /
      Last update: 2012-02-27 08:43    [W:0.028 / U:2.524 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site