[lkml]   [2012]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs
On Thu, Feb 23, 2012 at 2:33 PM, Ingo Molnar <> wrote:
> At the risk of being flamed some more, where does the confusion
> stem from?

From the fact that "very" is an English word that means "very", and
"unlikely()" and "likely()" are already used in their obvious meaning.

So quite frankly, "very_unlikely()" quite naturally means something
else than you are trying to make it mean.

The fact that EVERY SINGLE OTHER OPERATION that worked on that data
structure used to be named "jump_label_xyz()" and is now named
"static_key_xyz()" is also a big clue, I think. Naming it anything
else was always a mistake.

Seriously, I don't understand why you don't just use the obvious name.
The data structure is named "static_key". The things that change it
are named "static_key_inc()" or something. So a name like
"static_key_true()" is simply *better*, isn't it?

It's not just about less confusion, it's actually about just having
consistent naming.


 \ /
  Last update: 2012-02-23 23:49    [W:0.095 / U:2.572 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site