[lkml]   [2012]   [Feb]   [23]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs
On Thu, Feb 23, 2012 at 2:02 AM, Ingo Molnar <> wrote:
> Having to take the address gives us type safety - i.e. it will
> not be possible to accidentally pass in a non-jump-label key and
> get it misinterpreted.

Ingo, stop with the stupid denialism.

NOBODY likes that name. NOBODY. It's wrong. It's stupid. It sounds
like a stronger "unlikely()", and it simply IS NOT.

So rename it already.

The "type safety" argument seems bogus too. As far as I can tell, it
fails miserably if you test a void pointer for being NULL.

Sure, you can fix that by doing crazy things to the interface, but in
the end, nothing changes the fact that "very_unlikely()" as a name
sounds like an emphatic version of "unlikely()".

Rename it. Make it clear from the name that it is about these static
variables. Everything else seems to be named for that "static_key"
thing, so make the testing of it be named that way too, instead of
using a bad generic naming scheme that is just confusing.


 \ /
  Last update: 2012-02-23 18:21    [W:0.089 / U:12.920 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site