lkml.org 
[lkml]   [2012]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs
    From
    Date
    The bike shed is getting really dark.

    On Wed, 2012-02-22 at 09:20 -0500, Mathieu Desnoyers wrote:
    >
    > [...]
    > One possible naming that might be a good fit:
    >
    > - read_always_likely()
    > - read_always_unlikely()
    > - read_always_branch()
    >
    > I think it is important to convey both that it is expected to be always
    > read, pretty much never updated, and the bias, or absence of bias.

    That actually looks even more confusing. "read_always"? What the hell is
    that?

    >
    > I also _like_ to have a relatively long name here, because the update
    > cost is so high that someone should really think before using this
    > facility. In my opinion, it's not "just" a stronger likely/unlikely.

    Then make it what it is (with a long name...)

    if (jump_label_likely())

    if (jump_label_unlikely())

    That's probably the least confusing of the names. And for the cases we
    don't care:

    if (jump_label_branch())

    The above is the most descriptive and I would say the least confusing.
    Someone on IRC said that they wish it had jump_label in the name. As
    they see there's a "CONFIG_JUMP_LABEL" it tells us where those jump
    labels are used.

    Need to go and knock down the bike shed now.

    -- Steve




    \
     
     \ /
      Last update: 2012-02-22 15:39    [W:0.022 / U:2.028 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site