[lkml]   [2012]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 00/10] jump label: introduce very_[un]likely + cleanups + docs
On Tue, Feb 21, 2012 at 12:09:20PM -0800, H. Peter Anvin wrote:
> On 02/21/2012 12:02 PM, Jason Baron wrote:
> > Hi,
> >
> > Renames 'static_branch()' -> very_unlikely(), hopefully, to be more intuitive
> > as to what jump labels is about. I'm also introducing 'very_likely()', as
> > the analogue to very_unlikely(). Patch is against the -tip perf branch.
> >
> Erk... I'm not happy about this. very_unlikely() makes it sound like it
> operates like unlikely(), which really is not the case. There is a huge
> difference in mechanism here as well as usage.
> -hpa

The naming discussion really stems from the addition of a default true

Originally we had 'static_branch()'. Then, in the first RFC introducing
the default true branch, I proposed: 'static_branch_def_false', and
'static_branch_def_true'. Did you like those better?

I'm not really too hung up on the naming, but I did think that
very_[un]likely were an interesting possibility.



 \ /
  Last update: 2012-02-21 21:23    [from the cache]
©2003-2014 Jasper Spaans. hosted at Digital Ocean