[lkml]   [2012]   [Feb]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [PATCH 1/2] vfs: Provide function to get superblock and wait for it to thaw
On Fri, Feb 10, 2012 at 10:48:58AM +0100, Jan Kara wrote:
> On Thu 09-02-12 10:37:20, Eric Sandeen wrote:
> > would "wait_for_thaw" vs. "thaw" be any clearer? Nitpicky I guess but the
> > meaning of "thawed" isn't immediately clear here. If it's already thawed? If
> > we want to wait for it it to be thawed? You can figure it out from the callers
> > but maybe a comment or a different name might help. No big deal.
> How about "wait_thaw". That should be explicit enough...

IMO, wait_for_thaw is much easier to read (i.e. better english ;) and
hence the code documents itself better. There's no reason to skimp
on characters here - it's not a heavily used variable....


Dave Chinner

 \ /
  Last update: 2012-02-11 00:19    [W:0.033 / U:3.452 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site