lkml.org 
[lkml]   [2012]   [Oct]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: [dm-devel] [PATCH v3 06/26] block: Add bio_end_sector()
    On Tue, Oct 02, 2012 at 02:10:01PM -0400, Vivek Goyal wrote:
    > On Mon, Sep 24, 2012 at 03:34:46PM -0700, Kent Overstreet wrote:
    >
    > [..]
    > > diff --git a/include/linux/bio.h b/include/linux/bio.h
    > > index 4e32be1..d985e90 100644
    > > --- a/include/linux/bio.h
    > > +++ b/include/linux/bio.h
    > > @@ -67,6 +67,7 @@
    > > #define bio_offset(bio) bio_iovec((bio))->bv_offset
    > > #define bio_segments(bio) ((bio)->bi_vcnt - (bio)->bi_idx)
    > > #define bio_sectors(bio) ((bio)->bi_size >> 9)
    > > +#define bio_end_sector(bio) ((bio)->bi_sector + bio_sectors(bio))
    >
    > May be it is just me. But bio_end_sector() kind of sounds that it will
    > calculate to the last sector of bio. So I thought of it more as
    > bio_last_sector() and not the sector which is next to the last sector.
    >
    > Will it make sense to introduce bio_last_sector() and use +1 everywhere.
    > Or may be we need a better name. Can't think of one though.

    Ugh, that sounds like it'd be just begging for fencepost errors. I've
    never ran into a situation where I needed bio->bi_sector +
    bio_sectors(bio) - 1, either.

    I kind of see your point... it seems like there should be a name for
    this concept (same as a pointer to the end of an array), but I can't
    think of one.


    \
     
     \ /
      Last update: 2012-10-02 23:01    [W:3.129 / U:0.040 seconds]
    ©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site