lkml.org 
[lkml]   [2012]   [Jan]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: iwl3945 didn't survive after s2ram failure
    On Thu 05-01-12 16:00:41, Stanislaw Gruszka wrote:
    > On Thu, Jan 05, 2012 at 03:19:13PM +0100, Michal Hocko wrote:
    > >
    > > OK, so I have tried to boot with pcie_aspm=off and the wireless
    > > resurrect. The I found out that I booted into 3.2 rather than 3.2-rc6 so
    > > I retested with the original kernel and guess what, yes it reported the
    > > same problem as before (with or without parameter).
    > > So I have tried to retest with few kernels (3.2.0-rc5,
    > > 3.2.0-rc6-00005-ga36bfdd, 3.2.0-rc7-00083-g115e8e7 and 3.2.0) that I
    > > still had on my machine and 3.2.0-rc6-00005-ga36bfdd seems to be the
    > > only affected one.
    > > There doesn't seem to be any obvious difference wrt. the driver in the
    > > logs (attached).
    > >
    > > Looking in the history it seems that 497f16f2 [pci: Fix hotplug of
    > > Express Module with pci bridges] might be related.
    >
    > From the changelog of that commit: "I noticed that the bridges get
    > assigned but do not get enabled", that looks like the problem we had
    > seen.

    Yes, I am just wondering why I haven't seen the problem before. I was
    using rc6 for quite some time and using suspend/resume cycle all the
    time. It was just after suspend didn't survive when I saw the problem
    for the first time...
    --
    Michal Hocko
    SUSE Labs
    SUSE LINUX s.r.o.
    Lihovarska 1060/12
    190 00 Praha 9
    Czech Republic


    \
     
     \ /
      Last update: 2012-01-05 17:27    [W:0.021 / U:61.364 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site