lkml.org 
[lkml]   [2012]   [Jan]   [30]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: iwlagn is getting even worse with 3.3-rc1
On Thu, Jan 26, 2012 at 04:06:36PM -0800, Emmanuel Grumbach wrote:
> On Thu, Jan 26, 2012 at 15:25, Norbert Preining <preining@logic.at> wrote:
> > Hi Emmanuel,
> >
> > On Do, 26 Jan 2012, Emmanuel Grumbach wrote:
> >> are suffering from the same issue. I am merging the mail threads here.
> >
> > First tests are promising, after reboot it was working immediately
> > without need to rfkill block/unblock. lso after suspend and resume.
> >
> > Will test more the next days and report back.
> >
> > dmesg output without debugging still the same, but connection
> > continues without any problem:
> > [   62.437916] Open BA session requested for 00:0a:79:eb:56:10 tid 0
> > [   62.456184] activated addBA response timer on tid 0
> > [   63.456042] addBA response timer expired on tid 0
> > [   63.456063] Tx BA session stop requested for 00:0a:79:eb:56:10 tid 0
> > [   67.008297] switched off addBA timer for tid 0
> > [   67.008305] got addBA resp for tid 0 but we already gave up
> > [   67.008340] Stopping Tx BA session for 00:0a:79:eb:56:10 tid 0
> > [   67.015503] Open BA session requested for 00:0a:79:eb:56:10 tid 0
> > [   67.031648] activated addBA response timer on tid 0
> > [   67.129907] switched off addBA timer for tid 0
> > [   67.129914] Aggregation is on for tid 0
> > [   67.130076] iwlwifi 0000:06:00.0: Tx aggregation enabled on ra = 00:0a:79:eb:56:10 tid = 0
> > [  100.288018] tx session timer expired on tid 0
> > [  100.288032] Tx BA session stop requested for 00:0a:79:eb:56:10 tid 0
> > [  106.347302] Stopping Tx BA session for 00:0a:79:eb:56:10 tid 0
> > [  106.374760] Open BA session requested for 00:0a:79:eb:56:10 tid 0
> > [  106.388178] activated addBA response timer on tid 0
> > [  106.390041] switched off addBA timer for tid 0
> > [  106.390044] Aggregation is on for tid 0
> > [  106.390193] iwlwifi 0000:06:00.0: Tx aggregation enabled on ra = 00:0a:79:eb:56:10 tid = 0
> > [  135.786765] Open BA session requested for 00:0a:79:eb:56:10 tid 6
> > [  135.804164] activated addBA response timer on tid 6
> > [  135.806088] switched off addBA timer for tid 6
> > [  135.806092] Aggregation is on for tid 6
> > [  135.806241] iwlwifi 0000:06:00.0: Tx aggregation enabled on ra = 00:0a:79:eb:56:10 tid = 6
> > [  146.912031] tx session timer expired on tid 6
> > [  146.912071] Tx BA session stop requested for 00:0a:79:eb:56:10 tid 6
> > [  146.924187] Stopping Tx BA session for 00:0a:79:eb:56:10 tid 6
> > [  256.560100] tx session timer expired on tid 0
> > [  256.560132] Tx BA session stop requested for 00:0a:79:eb:56:10 tid 0
> > [  256.584379] Stopping Tx BA session for 00:0a:79:eb:56:10 tid 0
> > [  258.477345] Open BA session requested for 00:0a:79:eb:56:10 tid 0
> > [  258.500189] activated addBA response timer on tid 0
> > [  258.502148] switched off addBA timer for tid 0
> > [  258.502151] Aggregation is on for tid 0
> > [  258.502340] iwlwifi 0000:06:00.0: Tx aggregation enabled on ra = 00:0a:79:eb:56:10 tid = 0
> >
> > Later on after resume I got a few hickups but the connection just
> > hang for a shor ttime, then came back:
> > [  589.895086] delba from 00:0a:79:eb:56:10 (initiator) tid 0 reason code 39
> > [  589.895095] Rx BA session stop requested for 00:0a:79:eb:56:10 tid 0 inititator reason: 0
> > [  589.900879] Rx A-MPDU request on tid 0 result 0
> > [  589.900950] unexpected AddBA Req from 00:0a:79:eb:56:10 on tid 0
> > [  589.900958] Rx BA session stop requested for 00:0a:79:eb:56:10 tid 0 recipient reason: 32
> > [  589.902649] Rx A-MPDU request on tid 0 result 0
> > [  589.902690] unexpected AddBA Req from 00:0a:79:eb:56:10 on tid 0
> > [  589.902698] Rx BA session stop requested for 00:0a:79:eb:56:10 tid 0 recipient reason: 32
> > [  589.903732] Rx A-MPDU request on tid 0 result 0
> > [  589.903810] unexpected AddBA Req from 00:0a:79:eb:56:10 on tid 0
> > [  589.903817] Rx BA session stop requested for 00:0a:79:eb:56:10 tid 0 recipient reason: 32
> > [  589.904965] Rx A-MPDU request on tid 0 result 0
> > [  589.905045] unexpected AddBA Req from 00:0a:79:eb:56:10 on tid 0
> > [  589.905053] Rx BA session stop requested for 00:0a:79:eb:56:10 tid 0 recipient reason: 32
> > [  589.906510] Rx A-MPDU request on tid 0 result 0
> > [  590.456062] ieee80211 phy0: release an RX reorder frame due to timeout on earlier frames
> > [  590.456075] ieee80211 phy0: release an RX reorder frame due to timeout on earlier frames
> > [  590.456083] ieee80211 phy0: release an RX reorder frame due to timeout on earlier frames
> > [  594.413810] delba from 00:0a:79:eb:56:10 (initiator) tid 0 reason code 39
> > [  594.413822] Rx BA session stop requested for 00:0a:79:eb:56:10 tid 0 inititator reason: 0
> > [  594.428073] Rx A-MPDU request on tid 0 result 0
> >
> >
> > Generally fine.
> >
> > Thanks, more reports later.
> >
>
> Dave ?

after running with it all evening, it seems to be working fine so far.

(Sorry for delay, been on vacation for a week)

Dave

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2012-01-31 03:45    [W:0.089 / U:6.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site